Discussion:
ipa-finduser problem
(too old to reply)
Shan Kumaraswamy
2010-07-08 13:43:35 UTC
Permalink
Dear All,

[***@saprhds001 sbin]# kinit admin
Password for ***@MYDOMAIN.COM:
[***@saprhds001 sbin]# klist
Ticket cache: FILE:/tmp/krb5cc_0
Default principal: ***@MYDOMAIN.COM
Valid starting Expires Service principal
07/08/10 16:37:47 07/09/10 16:37:43 krbtgt/***@MYDOMAIN.COM

Kerberos 4 ticket cache: /tmp/tkt0
klist: You have no tickets cached
[***@saprhds001 sbin]# /usr/sbin/ipa-finduser admin
There was a problem importing one of the required Python modules. The
error was:
No module named kerberos

And when I try to restart the ipa server, the ipa_webgui service is not
shouting down and web server not working. Please advice me what went wrong?
--
Thanks & Regards
Shan Kumaraswamy
Shan Kumaraswamy
2010-07-08 15:29:54 UTC
Permalink
Dear All,
FreeIPA ipa_webgui not starting

Please find the below error message:

[***@saprhds001 ~]# /usr/sbin/ipactl restart
Shutting down ipa_webgui: [FAILED]
Shutting down ipa_kpasswd: [ OK ]
Stopping httpd: [ OK ]
Stopping Kerberos 5 KDC: [ OK ]
Shutting down dirsrv:
MYDOMAIN-COM... [ OK ]
Shutting down ntpd: [ OK ]
Starting dirsrv:
MYDOMAIN-COM... [ OK ]
Starting ntpd: [ OK ]
Starting Kerberos 5 KDC: [ OK ]
Starting ipa_kpasswd: [ OK ]
Starting ipa_webgui: [ OK ]
Starting httpd: [ OK ]
[***@saprhds001 ~]# tail -f /var/log/ipa_error.log
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 2479, in ?
working_set.require(__requires__)
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 585, in
require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 483, in
resolve
raise DistributionNotFound(req) # XXX put more info here

Please help me to fix this issue.
Post by Shan Kumaraswamy
Dear All,
Ticket cache: FILE:/tmp/krb5cc_0
Valid starting Expires Service principal
Kerberos 4 ticket cache: /tmp/tkt0
klist: You have no tickets cached
There was a problem importing one of the required Python modules. The
No module named kerberos
And when I try to restart the ipa server, the ipa_webgui service is not
shouting down and web server not working. Please advice me what went wrong?
--
Thanks & Regards
Shan Kumaraswamy
--
Thanks & Regards
Shan Kumaraswamy
Rob Crittenden
2010-07-08 15:48:01 UTC
Permalink
Post by Shan Kumaraswamy
Dear All,
FreeIPA ipa_webgui not starting
Shutting down ipa_webgui: [FAILED]
Shutting down ipa_kpasswd: [ OK ]
Stopping httpd: [ OK ]
Stopping Kerberos 5 KDC: [ OK ]
MYDOMAIN-COM... [ OK ]
Shutting down ntpd: [ OK ]
MYDOMAIN-COM... [ OK ]
Starting ntpd: [ OK ]
Starting Kerberos 5 KDC: [ OK ]
Starting ipa_kpasswd: [ OK ]
Starting ipa_webgui: [ OK ]
Starting httpd: [ OK ]
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 2479, in ?
working_set.require(__requires__)
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 585, in
require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 483, in
resolve
raise DistributionNotFound(req) # XXX put more info here
Please help me to fix this issue.
Do you have any more context on this? Does it say anywhere what is not
being found?

What is your distribution and where did you get the packages?

We've gotten reports of people trying to build ipa in CentOS and having
problems like this related to python-cheetah. I've never seen a
resolution nor have I been able to duplicate the problem so I'm not sure
what the next step is, other than verifying that you have python-cheetah
installed.

rob
Post by Shan Kumaraswamy
Dear All,
Ticket cache: FILE:/tmp/krb5cc_0
Valid starting Expires Service principal
07/08/10 16:37:47 07/09/10 16:37:43
Kerberos 4 ticket cache: /tmp/tkt0
klist: You have no tickets cached
There was a problem importing one of the required Python modules. The
No module named kerberos
And when I try to restart the ipa server, the ipa_webgui service is
not shouting down and web server not working. Please advice me what
went wrong?
--
Thanks & Regards
Shan Kumaraswamy
--
Thanks & Regards
Shan Kumaraswamy
------------------------------------------------------------------------
_______________________________________________
Freeipa-users mailing list
https://www.redhat.com/mailman/listinfo/freeipa-users
Konstantin Kozlov
2010-07-09 05:27:29 UTC
Permalink
As you use python 2.4 it is probably CentOS 5.

Check if you have SPICE libs installed:
tclspice-20-3.el5
qspice-libs-0.3.0-39.el5_4.3
qspice-0.3.0-39.el5_4.3
In CentOS rpm dependencies were
broken sometime ago when I tried to install FreeIPA.

Best regards,

Kostya


On Thu, 08 Jul 2010 11:48:01 -0400
Post by Rob Crittenden
Post by Shan Kumaraswamy
Dear All,
FreeIPA ipa_webgui not starting
Shutting down ipa_webgui: [FAILED]
Shutting down ipa_kpasswd: [ OK ]
Stopping httpd: [ OK ]
Stopping Kerberos 5 KDC: [ OK ]
MYDOMAIN-COM... [ OK ]
Shutting down ntpd: [ OK ]
MYDOMAIN-COM... [ OK ]
Starting ntpd: [ OK ]
Starting Kerberos 5 KDC: [ OK ]
Starting ipa_kpasswd: [ OK ]
Starting ipa_webgui: [ OK ]
Starting httpd: [ OK ]
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
2479, in ? working_set.require(__requires__)
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
585, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
483, in resolve
raise DistributionNotFound(req) # XXX put more info here
Please help me to fix this issue.
Do you have any more context on this? Does it say anywhere what is
not being found?
What is your distribution and where did you get the packages?
We've gotten reports of people trying to build ipa in CentOS and
having problems like this related to python-cheetah. I've never seen
a resolution nor have I been able to duplicate the problem so I'm not
sure what the next step is, other than verifying that you have
python-cheetah installed.
rob
Post by Shan Kumaraswamy
On Thu, Jul 8, 2010 at 4:43 PM, Shan Kumaraswamy
Dear All,
Ticket cache: FILE:/tmp/krb5cc_0
Service principal 07/08/10 16:37:47 07/09/10 16:37:43
Kerberos 4 ticket cache: /tmp/tkt0
klist: You have no tickets cached
There was a problem importing one of the required Python
No module named kerberos
And when I try to restart the ipa server, the ipa_webgui
service is not shouting down and web server not working. Please
advice me what went wrong?
--
Thanks & Regards
Shan Kumaraswamy
--
Thanks & Regards
Shan Kumaraswamy
------------------------------------------------------------------------
_______________________________________________
Freeipa-users mailing list
https://www.redhat.com/mailman/listinfo/freeipa-users
_______________________________________________
Freeipa-users mailing list
https://www.redhat.com/mailman/listinfo/freeipa-users
Rob Crittenden
2010-07-09 13:01:52 UTC
Permalink
Rob/ Kostya,
Thanks for your quick response, as per Rob’s note I have compared the
old installation and new system installation, and I find that there is a
different versions of “python-cheetah” rpm, so I removed old version and
installed appropriate version, now I can find the admin user as well as
ipa_webgui is working properly
Glad to hear it. Do you happen to have the details on the version that
works?

thanks

rob
As you use python 2.4 it is probably CentOS 5.
tclspice-20-3.el5
qspice-libs-0.3.0-39.el5_4.3
qspice-0.3.0-39.el5_4.3
In CentOS rpm dependencies were
broken sometime ago when I tried to install FreeIPA.
Best regards,
Kostya
On Thu, 08 Jul 2010 11:48:01 -0400
Post by Rob Crittenden
Post by Shan Kumaraswamy
Dear All,
FreeIPA ipa_webgui not starting
Shutting down ipa_webgui: [FAILED]
Shutting down ipa_kpasswd: [ OK ]
Stopping httpd: [ OK ]
Stopping Kerberos 5 KDC: [ OK ]
MYDOMAIN-COM... [ OK ]
Shutting down ntpd: [ OK ]
MYDOMAIN-COM... [ OK ]
Starting ntpd: [ OK ]
Starting Kerberos 5 KDC: [ OK ]
Starting ipa_kpasswd: [ OK ]
Starting ipa_webgui: [ OK ]
Starting httpd: [ OK ]
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
2479, in ? working_set.require(__requires__)
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
585, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
483, in resolve
raise DistributionNotFound(req) # XXX put more info here
Please help me to fix this issue.
Do you have any more context on this? Does it say anywhere what is
not being found?
What is your distribution and where did you get the packages?
We've gotten reports of people trying to build ipa in CentOS and
having problems like this related to python-cheetah. I've never seen
a resolution nor have I been able to duplicate the problem so I'm not
sure what the next step is, other than verifying that you have
python-cheetah installed.
rob
Post by Shan Kumaraswamy
On Thu, Jul 8, 2010 at 4:43 PM, Shan Kumaraswamy
Dear All,
Ticket cache: FILE:/tmp/krb5cc_0
starting Expires
Post by Rob Crittenden
Post by Shan Kumaraswamy
Service principal 07/08/10 16:37:47 07/09/10 16:37:43
<http://mydomain.com/>
Post by Rob Crittenden
Post by Shan Kumaraswamy
<mailto:krbtgt <mailto:krbtgt>/BMIBANK.COM
Kerberos 4 ticket cache: /tmp/tkt0
klist: You have no tickets cached
There was a problem importing one of the required Python
No module named kerberos
And when I try to restart the ipa server, the ipa_webgui
service is not shouting down and web server not working. Please
advice me what went wrong?
--
Thanks & Regards
Shan Kumaraswamy
--
Thanks & Regards
Shan Kumaraswamy
------------------------------------------------------------------------
Post by Rob Crittenden
Post by Shan Kumaraswamy
_______________________________________________
Freeipa-users mailing list
https://www.redhat.com/mailman/listinfo/freeipa-users
_______________________________________________
Freeipa-users mailing list
https://www.redhat.com/mailman/listinfo/freeipa-users
_______________________________________________
Freeipa-users mailing list
https://www.redhat.com/mailman/listinfo/freeipa-users
--
Thanks & Regards
Shan Kumaraswamy
Shan Kumaraswamy
2010-07-11 07:04:40 UTC
Permalink
Sure Rob,
Please find the below details:

python-cheetah-2.0.1-1.el5.rf.x86_64.rpm (removed) from the current server
and installed this version of python-cheetah-2.0.1-1.el5.x86_64.rpm
(Installed New)
Post by Rob Crittenden
Rob/ Kostya,
Thanks for your quick response, as per Rob’s note I have compared the old
installation and new system installation, and I find that there is a
different versions of “python-cheetah” rpm, so I removed old version and
installed appropriate version, now I can find the admin user as well as
ipa_webgui is working properly
Glad to hear it. Do you happen to have the details on the version that
works?
thanks
rob
As you use python 2.4 it is probably CentOS 5.
tclspice-20-3.el5
qspice-libs-0.3.0-39.el5_4.3
qspice-0.3.0-39.el5_4.3
In CentOS rpm dependencies were
broken sometime ago when I tried to install FreeIPA.
Best regards,
Kostya
On Thu, 08 Jul 2010 11:48:01 -0400
Post by Rob Crittenden
Post by Shan Kumaraswamy
Dear All,
FreeIPA ipa_webgui not starting
[FAILED]
Post by Rob Crittenden
Post by Shan Kumaraswamy
Shutting down ipa_kpasswd: [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
Stopping httpd: [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
Stopping Kerberos 5 KDC: [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
MYDOMAIN-COM... [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
Shutting down ntpd: [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
MYDOMAIN-COM... [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
Starting ntpd: [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
Starting Kerberos 5 KDC: [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
Starting ipa_kpasswd: [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
Starting ipa_webgui: [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
Starting httpd: [ OK
]
Post by Rob Crittenden
Post by Shan Kumaraswamy
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
2479, in ? working_set.require(__requires__)
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
585, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.4/site-packages/pkg_resources.py", line
483, in resolve
raise DistributionNotFound(req) # XXX put more info here
Please help me to fix this issue.
Do you have any more context on this? Does it say anywhere what is
not being found?
What is your distribution and where did you get the packages?
We've gotten reports of people trying to build ipa in CentOS and
having problems like this related to python-cheetah. I've never seen
a resolution nor have I been able to duplicate the problem so I'm
not
Post by Rob Crittenden
sure what the next step is, other than verifying that you have
python-cheetah installed.
rob
Post by Shan Kumaraswamy
On Thu, Jul 8, 2010 at 4:43 PM, Shan Kumaraswamy
Dear All,
Ticket cache: FILE:/tmp/krb5cc_0
starting Expires
Post by Rob Crittenden
Post by Shan Kumaraswamy
Service principal 07/08/10 16:37:47 07/09/10 16:37:43
krbtgt/BMIBANK.COM <http://bmibank.com/> <http://bmibank.com/
@MYDOMAIN.COM <http://mydomain.com/>
<http://mydomain.com/>
Post by Rob Crittenden
Post by Shan Kumaraswamy
<mailto:krbtgt <mailto:krbtgt>/BMIBANK.COM <http://bmibank.com/>
http://mydomain.com/>>
Post by Rob Crittenden
Post by Shan Kumaraswamy
Kerberos 4 ticket cache: /tmp/tkt0
klist: You have no tickets cached
There was a problem importing one of the required Python
No module named kerberos
And when I try to restart the ipa server, the ipa_webgui
service is not shouting down and web server not working. Please
advice me what went wrong?
--
Thanks & Regards
Shan Kumaraswamy
--
Thanks & Regards
Shan Kumaraswamy
------------------------------------------------------------------------
Post by Rob Crittenden
Post by Shan Kumaraswamy
_______________________________________________
Freeipa-users mailing list
https://www.redhat.com/mailman/listinfo/freeipa-users
_______________________________________________
Freeipa-users mailing list
https://www.redhat.com/mailman/listinfo/freeipa-users
_______________________________________________
Freeipa-users mailing list
https://www.redhat.com/mailman/listinfo/freeipa-users
--
Thanks & Regards
Shan Kumaraswamy
--
Thanks & Regards
Shan Kumaraswamy
Rob Crittenden
2010-07-08 15:30:03 UTC
Permalink
Post by Shan Kumaraswamy
Dear All,
Ticket cache: FILE:/tmp/krb5cc_0
Valid starting Expires Service principal
Kerberos 4 ticket cache: /tmp/tkt0
klist: You have no tickets cached
There was a problem importing one of the required Python modules. The
No module named kerberos
And when I try to restart the ipa server, the ipa_webgui service is not
shouting down and web server not working. Please advice me what went wrong?
You need the python-kerberos package. Did you install this from source?
Our dependencies within the source tree are a bit weak but installing
using rpms should have required it.

For the restart problem, how are you restarting things? Can you look in
/var/log/ipa_error.log to see if anything is logged? This is the web UI
(TurboGears) error log. The Apache log in /var/log/httpd/error_log might
have some relevant details as well.

rob
Shan Kumaraswamy
2010-07-08 16:18:18 UTC
Permalink
Rob,
After installed python-kerberos, now I can able to find the admin user.
still I could not able to start ipa_webgui.

please advice
Post by Shan Kumaraswamy
Dear All,
Ticket cache: FILE:/tmp/krb5cc_0
Valid starting Expires Service principal
Kerberos 4 ticket cache: /tmp/tkt0
klist: You have no tickets cached
There was a problem importing one of the required Python modules. The
No module named kerberos
And when I try to restart the ipa server, the ipa_webgui service is not
shouting down and web server not working. Please advice me what went wrong?
--
Thanks & Regards
Shan Kumaraswamy
--
Thanks & Regards
Shan Kumaraswamy
Continue reading on narkive:
Loading...